Fxpansion.com Forum Index
RegisterSearchFAQ UsergroupsLog in
Reply to topic Page 2 of 4
Goto page Previous  1, 2, 3, 4  Next
Incompatible plug-ins thread
Author Message
Reply with quote
Post  
Hey Angus,

Synful Orchestra is not supported, wrapping process goes well but the pugin has no access to any of it's controls.
PT-HD7.x(beta), MacPro 2.66

Marcello Azevedo

View user's profile Send private message
Reply with quote
Post Wrapped plug ins not functioning correctly 
Last week I downloaded the excellent suite from TAL (Chorus 60, U-No 60, Dub delay & Vintager) which has recently been made available as intel mac vst (I'm on a mac pro 2 X 3 ghz with 2 gig memory 10.4.1 running PT LE 7.3cs1) all of them wrap but then suffer from the "frozen" gui syndrome mentioned elsewhere. If presets exist they can be stepped through no problem and the plugs are otherwise stable. Patrick from TAL is looking into the problem from his end to see if something can be done but also pointed out this problem exists with many other plug ins as shown by posts on this forum. I've also recently been playing with Slayer 2 which works quite well as a plug in only it cannot be removed from a track once inserted! The developers there were amazed it worked at all as I don't think they'd imagined anyone would use it outside of Cubase!

So I thought I'd go through the plug ins I have (some of which are demos and all of which date from the last couple of months) and see what else is not functioning correctly. The following suffer from frozen gui.

Flux - Bitter sweet
TAL - Chorus 60, U-No 60, Dub delay, Vintage
NuGen audio- Line Up V2
MDSP - Live Cut
Expert Sleepers - Meringue, Warbler
Retro Band lite
SFX Machine Pro
Sugar Bytes - Vogue

Other problematic ones are the aforementioned slayer 2 &

Storm Gate - which crashes PT if you try to edit any of the parameters


cheers

c.

View user's profile Send private message
Reply with quote
Post  
Angus_FX wrote:
I don't know RSO.. what's their URL? also are you on mac or pc?


http://www.recordingschoolonline.com/documents/73.html

I'm on a pc.

View user's profile Send private message
Reply with quote
Post  
The frozen GUI thing is not our fault - you need to contact those developers and tell them to fix their plug-ins. Unfortunately, Steinberg supplied a lot of developers with a broken version of the VST GUI library (which plug-ins use for their interface controls and graphics) which causes this bug, they need to tweak it slightly and then it all works.


_________________
-- Angus F. Hewlett - CEO - FXpansion --
Twitter | YouTube
Synth Squad | BFD Eco
View user's profile Send private message Visit poster's website
Reply with quote
Post  
Yellowtools has a 2GB freebie VST called "Independence Free".
The VST itself is 75 MB, rest is library.

Attempting to wrap it with v2.1 of the wrapper (am I up to date?) gets :
"Independence Free could not be wrapped. Please consult the VST wrapp.."
( text cuts off at end of Fxpansion window, scrolling right is not available ).

EDIT :
Managed to get it wrapped by choosing the "redetect" option from the pull-down Tools menu ....
but unfortunately we'll have to add this one to the "frozen GUI" list.



Last edited by Simon666 on Fri Sep 21, 2007 2:34 pm; edited 1 time in total
View user's profile Send private message
Reply with quote
Post  
Angus_FX wrote:
The frozen GUI thing is not our fault - you need to contact those developers and tell them to fix their plug-ins.


I'm not so sure Angus .... this seems to also be a Protools-Fxpansion thing. I'm going back and forth between PT LE 7.0 (home) and 7.1 (work). Trying the same plugs (same files even) with the Fxpansion 2.1 wrapper.

Many of the "frozen' ones (Triple Cheese, CM Zebra, the new "TAL" ones that someone else has mentioned) are fine on Protools 7.0 , but not 7.1 (and 7.3, by the sound of what people are saying). So while it's clear that there's something in the VST spec that you're pointing to, there's also something that changed between the Fxpansion_Protools relationsip between PT LE 7.0 and 7.1.

Simon

View user's profile Send private message
Reply with quote
Post Again, not our fault 
I would have to agree with you Simon666. Things seemed to work better in 7.0, then I updated to 7.3 and it all changed. I'm noticing a trend throughout a lot of the threads in this forum, it's basiclly this:

Angus_FX wrote:
The frozen GUI thing is not our fault - you need to contact those developers and tell them to fix their plug-ins. Unfortunately, Steinberg supplied a lot of developers with a broken version of the VST GUI library (which plug-ins use for their interface controls and graphics) which causes this bug, they need to tweak it slightly and then it all works.


View user's profile Send private message
Reply with quote
Post PC WinXP Pro SP2 Protools 7.1.3rc4 Nexus compatibility 
Hi all

is anybody know about compatibility with nexus
I want to uprade to nexus 1.3.7 for last expansion pack
I've read about the framework, using 3.5
fxpansion VST to RTAS 2.1

Apparently a lot of issue with protools so any help please ?
I' m sure some0ne has tested this shit... Cool

View user's profile Send private message
Reply with quote
Post Independence Free 2.0 incompatible with VST to RTAS 2.1 on MAC? 
Independence free 2.0 does not work with FXPansion VST to RTAS Converter 2.1. All Buttons and Knobs do not move. The Plug In is Frozen.

But Independence free 2.0 works in NI KORE 2 inside Protools.


Hardware Dual G5 2 Ghz, 4,5 GB RAM, Protools HD2 mit 96 IO, MAC OS X 10.4.11

View user's profile Send private message Visit poster's website AIM Address
Reply with quote
Post Independence Free 2.0 incompatible with VST to RTAS 2.1 on MAC 
I got an email by Yellow Tools. Independence Free 2.0 is a VSTi 2.4 plugIn. VST 2.4 can not be wrapped by the actual version of the VST to RTAS converter.

View user's profile Send private message Visit poster's website AIM Address
Reply with quote
Post  
Angus_FX wrote:
The frozen GUI thing is not our fault - you need to contact those developers and tell them to fix their plug-ins. Unfortunately, Steinberg supplied a lot of developers with a broken version of the VST GUI library (which plug-ins use for their interface controls and graphics) which causes this bug, they need to tweak it slightly and then it all works.


Hi Angus. I'm going through the same problems with one of my plugins using VSTGUI3.6 (apulSoft apEQ). Could you explain what you mean by "tweak it slightly"? What I see is that the adapter uses non-composited windows to host the GUI, which IMHO is not really supported on intel macs and thus the event queue does not work right..? I'm also seeing problems(crashes) when beginEdit() and endEdit() call the audiomaster on intel macs. My email: "techhelp __at__ apulsoft __dot__ ch"

View user's profile Send private message
Reply with quote
Post  
Angus_FX wrote:
The frozen GUI thing is not our fault - you need to contact those developers and tell them to fix their plug-ins. Unfortunately, Steinberg supplied a lot of developers with a broken version of the VST GUI library (which plug-ins use for their interface controls and graphics) which causes this bug, they need to tweak it slightly and then it all works.


Hi Angus. I'm going through the same problems with one of my plugins using VSTGUI3.6 (apulSoft apEQ). Could you explain what you mean by "tweak it slightly"? What I see is that the adapter uses non-composited windows to host the GUI, which IMHO is not really supported on intel macs and thus the event queue does not work right..? I'm also seeing problems(crashes) when beginEdit() and endEdit() call the audiomaster on intel macs. My email: "techhelp __at__ apulsoft __dot__ ch"

View user's profile Send private message
Reply with quote
Post  
VST-RTAS has always used non compositing windows, you just need to make sure that a) the mouse()/draw() code path has not been #def'ed out in your build with all the silly deprecation macros (why in the blue hell did they deprecate stuff in 2.4 when they were only going to go and break the whole fragging thing completely and utterly in 3.0? seriously, there is something very very wrong in the coffee supply over in Hamburg...), and b) your event handling code can install suitable event handlers and suchlike for both compositing windows (create a UserPane and attach control event listeners) and non compositing (install kEventClassMouse and kEventWindowDraw on the provided WindowRef).

Hope that helps,
Angus.


_________________
-- Angus F. Hewlett - CEO - FXpansion --
Twitter | YouTube
Synth Squad | BFD Eco
View user's profile Send private message Visit poster's website
Reply with quote
Post  
Thank you very much, Angus. Your reply allowed me to patch VSTGUI the right way and now things seem to work well with the wrapper.

View user's profile Send private message
Reply with quote
Post  
Ive got the frozen GUI problem with Sonic Charge's Synplant, all of Tone2's plug-ins, Audio Damage's Rough Rider and Automaton - Pro Tools 7.4.2, OSX 10.5.5.

I've contacted all of them and so far...zilch.

Is there nothing FXpansion can do to patch the adapter to get around this problem?

View user's profile Send private message
Display posts from previous:
Reply to topic Page 2 of 4
Goto page Previous  1, 2, 3, 4  Next
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum