Fxpansion.com Forum Index
RegisterSearchFAQ UsergroupsLog in
Reply to topic Page 1 of 1
Latency issues...I think...
Author Message
Reply with quote
Post Latency issues...I think... 
Hi....New BFD2 user here and after some frustration setting up I finally have BFD talking to my interface and to my computer. The problem is now that I have my td9 triggering the sounds i'm getting some "choking" of notes when I play fast and also when I play a fast tempo groove it's like the sounds can't keep up...Latency? At slow speeds I can detect a very small latency from when I hit to when the sound regesters...barely anything and it doesn't bother me because all the notes articulate properly. The cutting off only occurs at higher speeds and tempos. Makes it sound fake.

It's irritating because I am running a brand new quad core computer with 4 gigs of ram through a presonus firebox set at the lowest latencey it has...(I've seen others on youtube who get zero latency with these). I would think this would be more than enough computer power to handle BFD.

I've played around with the triggering options in the td 9 as well. Any suggestions would be helpful. I'm sure there are just some settings I need to tweak but not sure what.

thanks

View user's profile Send private message
Reply with quote
Post  
What you are hearing is a RAM buffer and Streaming buffer issue in BFD2. Consult your manual and make the adjustments on the preferences page.

You also want to make sure that you are in 16bit mode.

John

View user's profile Send private message Visit poster's website
Reply with quote
Post  
Thanks for the advice John. I put it into 16 bit mode and played with those settings...but...

I found out that my in my own stupidity I had the firebox setting on the wrong one. I didn't select the AISO...when I did the difference was amazing.....virtually zero latency.....

I could even put it back to 32 bit mode and it played the same. Should I be doing this or not? BFD will sometimes tell me I'm out of memory if I try to use all the fastest settings...and won't load some kit pieces. As I mentioned I have 4 gigs of RAM on a 400 gig hard drive...a new computer with virtually no other programs running aside from an anti virus and the firebox software. Is BFD really using that much? If not is their anyway to allocate more RAM for BFD and firebox?

I still some times get very slight drop outs with very fast HH parts and I don't think I can tweak BFD any more than I already have..My presonus manual says that I might need to lower the latency on the firebox. I'll continue to play around but I finally feel like it is nearly 100%.

Thanks again.

View user's profile Send private message
Reply with quote
Post  
ASIO is correct! To reduce your memory usage set the RAM cache to 8k in the Engine prefs. To let Windows use more than 2GB of RAM you need to enable the /3G switch.

Rail


_________________

View user's profile Send private message Visit poster's website
Reply with quote
Post Ram cache 
Will setting the ram cache to 8k have any negative effect on sound or performance?

View user's profile Send private message
Reply with quote
Post  
Not if your system is fast enough.

Rail


_________________

View user's profile Send private message Visit poster's website
Reply with quote
Post Cache 
So it will increase CPU usage?

View user's profile Send private message
Reply with quote
Post  
Thanks Rail,,,

By RAM cache you mean where it says RAM Buffer on BFD2 right? Not the Max Cache buffer setting? And forgive my ignorance but where is this 3Gig switch thing? My computer properties tell me I have 3.5 something gigs but I'd like to make sure they are all being utilized. I'll continue to mess with the settings a bit more.

Today I lowered the latency on the firebox a little bit (with no perceivable effects...really amazing) and played with some of the roland settings....did what I think you were suggesting and put the RAM Buffer on 8k and then 16k just to see what would happen. It seems to be working really well. No more drop outs at all.

I do get what seems like a drop out when I do quick HH closes but I'm starting to think it's not computer speed but the way BFD recognizes a closed HH. Like it's too sudden and stops the last note hit on the way down....Any ideas anyone?

Thanks for all you're help you guys....I'm actually starting to enjoy the challenge of getting this thing set up absolutely perfectly.

View user's profile Send private message
Reply with quote
Post Enabling the 3GB switch 
Platinum Samples wrote:
ASIO is correct! To reduce your memory usage set the RAM cache to 8k in the Engine prefs. To let Windows use more than 2GB of RAM you need to enable the /3G switch.

Rail


I'm glad u wrote this thread...my BFD was hummin along until I kep hitting issues at...2GB!!
Updating my boot.ini right now Very Happy

For those that are interested, it goes something like this:

from http://www.microsoft.com/whdc/system/platform/server/PAE/PAEmem.mspx

--------------------------------------------------------------------

The virtual address space of processes and applications is still limited to 2 GB,
unless the /3GB switch is used in the Boot.ini file.

The following example shows how to add the /3GB parameter in the Boot.ini file
to enable application memory tuning:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(2)\WINNT
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINNT="????" /3GB

---------------------------------------------------------------------

JT

View user's profile Send private message
Display posts from previous:
Reply to topic Page 1 of 1
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum