Forum

FXpansion Forum

Wrapper 2.1, Mac, works, but crashes when removing plugins, etc

Support for the VST To RTAS Adapter

Moderators: Drew_fx, SKoT_FX, Steve_FX, john emrich, Mully_FX, mayur_FX, Angus_FX, Andreas_FX, Rory_FX, Rhi_FX, Paul_fx, clare_fx, Moderators

rtcstudio
Posts: 3
Joined: Mon Dec 19, 2005 10:53 pm
Location: Tennessee

Wrapper 2.1, Mac, works, but crashes when removing plugins, etc

Postby rtcstudio » Sun Dec 09, 2012 4:42 pm

I just this week came back to this wrapper, bought the update and began to deal with the challenges.

At first it didn't work at all - it would wrap plugins, they would appear in Pro Tools under "Wrapped Plugins", but some of them would crash/freeze Pro Tools when trying to instantiate, or they would not pass audio.

After researching, I did change the permissions to "Read & Write" on the Application Support folder, as well as the Audio, Plugins and VST folders. I removed the VST3 folder, because I know this wrapper won't work with them.

After that, the required file com.fxpansion.fxshared.bundle DID appear in the Application Support folder. AND now, when I instantiate a plugin it will pass audio. I have for now limited which VST plugins I try, to hopefully avoid the freeze on instantiation. I'm just trying to troubleshoot this.

The plugin I was testing with was Ozone 5 (VST version, not VST3 - I could never determine which variety of VST 2.x it was, but it seems to work). This plugin worked great, as long as I left it alone - that is, when I try to remove it from the channel, Pro Tools will always freeze, spinning beach ball appears, and I have to Force Quit.

Is there anything else I can try to improve the experience here? Does anyone know if Ozone 5 is the un-approved 2.3 variety?

I filled out a Tech Support Ticket, but thought I'd post here as well.
Mac Pro 2 x 2.4 Ghz 6 core Intel Xenon, 48 GB RAM, Pro Tools 10.2.3 HD with TDM Hardware in Magma Expansion Chassis (core + 4 HD Accel).

Drew_fx
Posts: 3828
Joined: Fri Jul 21, 2006 5:32 pm
Location: London, UK

Re: Wrapper 2.1, Mac, works, but crashes when removing plugins, etc

Postby Drew_fx » Mon Dec 10, 2012 10:05 am

rtcstudio wrote:Does anyone know if Ozone 5 is the un-approved 2.3 variety?


You've got that the wrong way round. VST2.3 is supported, VST2.4 is not supported. I believe that Ozone is VST2.4.

rtcstudio
Posts: 3
Joined: Mon Dec 19, 2005 10:53 pm
Location: Tennessee

Postby rtcstudio » Mon Dec 10, 2012 2:36 pm

Thanks, Drew. So the crash on removal probably will be
solved by keeping to 2.3 VST's? Or are there other things
I can do to optimize my system for the wrapper?

How do you tell what version a VST is?

And more specifically, is the latest version of TC Powercore
in the 2.3 variety?

Thanks!
Mac Pro 2 x 2.4 Ghz 6 core Intel Xenon, 48 GB RAM, Pro Tools 10.2.3 HD with TDM Hardware in Magma Expansion Chassis (core + 4 HD Accel).


Return to “VST To RTAS Adapter”

Who is online

Users browsing this forum: No registered users and 3 guests