[FIXED: Data Patch available] Sabian AA Hats - 1/2 Shank articulation flamming between mics? - Fxpansion.com

Forum

FXpansion Forum

[FIXED: Data Patch available] Sabian AA Hats - 1/2 Shank articulation flamming between mics?

Support for BFD2 Acoustic Drum Workstation

Moderators: Drew_BFDTeam, Andreas_FX, Rory_FX, Rhi_FX, Paul_fx, clare_fx, SKoT_FX, Steve_FX, john emrich, Mully_FX, mayur_FX, Angus_FX, Moderators

Tim D
Posts: 18
Joined: Sun Jan 30, 2005 12:48 am

[FIXED: Data Patch available] Sabian AA Hats - 1/2 Shank articulation flamming between mics?

Postby Tim D » Wed Sep 12, 2012 7:01 am

Hi everybody - long time listener, first time caller :D
Apologies in advance if this is in the wrong area or has already been answered...

I'm having a problem with the Sabian AA Hats, on a single articulation only: the 1/2 Shank is "late" compared to all the others, but only in the ambient channels (OH RM Amb3) - the direct mic is "in time" with all of it's own articulations. This is happening consistently thru all velocity levels.

I noticed the same thing (but worse) on the Paiste Sound Edge while auditioning a replacement kit piece - I sniffed around here for info, then ran the patch from my BFD2 downloads in the user area, trashed and rebuilt. That fixed the issue for the Paiste Sound Edge (I recorded a "before and after" to make sure) but the Sabian AA hats are still fishy (which makes sense, the patch only mentioned the Paiste hats).

It's not a huge deal - basically, if I mute the direct mic during a "quicker" hat pattern (16th notes-ish) that alternates through the different articulations, my drummer sounds drunk.

I'm pretty sure* it's not user error, everything else is working normally.

I'm in PT 9.0.6, 2011 MBP w/8gb RAM (only the first 2gb are relevant though :? ), BFD2 data on it's own dedicated 7200rpm FW800 drive, high detail all pieces, nobody is going to read this, load on demand is on, "all hats variable" is off, load all to RAM is off, etc. Got same issue in standalone with different streaming engine settings.

See pic attached - the direct mic is panned left (the top waveform), all ambient channels are panned right (the bottom).
It's each articulation played once (at arbitrary velocity 124, on grid) from closed to open, shanks first (Ped, CS, CT, 1/4S, 1/4T, 1/2S, 1/2T, etc). The waveform with the black square below it is the articulation that's late.

I know, it sounds anal... I would usually have said "that's the way it is" if there wasn't a patch to fix the same kind of thing in another kit piece. And I like those hats ;) The Paiste was about 80ms late before the patch, this looks about 45ms.

Let me know if anybody has any ideas! Thanks lots, and sorry for the huge post...

*totally not sure

Image
Attachments
Sabian AA Hats waveforms.png
Sabian AA Hats waveforms.png (21.54 KiB) Viewed 3176 times

User avatar
sam_fx
Thought Police
Posts: 85
Joined: Tue Mar 16, 2010 8:18 am
Location: Perth, WA
Contact:

Postby sam_fx » Mon Sep 17, 2012 8:29 am

Hi Tim,

Wow that's a good catch! Thanks for that, I have reported it to the dev's, i'm sure they will get onto a data patch as soon as they can.

Cheers!

User avatar
SKoT_FX
Promulgator of Beats
Posts: 2419
Joined: Tue Sep 21, 2004 9:51 am
Location: FX Australia, Perth
Contact:

Postby SKoT_FX » Tue Sep 18, 2012 1:58 am

I've generated a fix, now with QA for checking+release. Man, "amusing" to see things like that can still be hiding in the data after 5 years...
SKoT McDonald
CTO FXpansion]

Tim D
Posts: 18
Joined: Sun Jan 30, 2005 12:48 am

Postby Tim D » Tue Sep 18, 2012 8:47 am

Thanks guys!

User avatar
AshleySmith08
Posts: 2206
Joined: Thu Dec 23, 2004 12:03 pm
Location: www.seattleunderground.co.uk
Contact:

Postby AshleySmith08 » Thu Sep 27, 2012 9:26 pm

Any further news guys?
Engineer/Producer/Musician/Media Content Creator
Website: http://www.seattleunderground.co.uk
CV: https://app.box.com/s/oiulec8q1eyqn2r0s46k
MacPro 12 Core 2x2.4 GHz, 24 GB Ram | MacBook Pro 2.8GHz i7, 16GB Ram
10.8.4/10.10.4, UA Apollo Quad, PT 12.x

User avatar
AshleySmith08
Posts: 2206
Joined: Thu Dec 23, 2004 12:03 pm
Location: www.seattleunderground.co.uk
Contact:

Postby AshleySmith08 » Thu Oct 04, 2012 4:32 pm

@FX_HQ, did the fix pass QA and is it ready for release? Thanks! :)
Engineer/Producer/Musician/Media Content Creator
Website: http://www.seattleunderground.co.uk
CV: https://app.box.com/s/oiulec8q1eyqn2r0s46k
MacPro 12 Core 2x2.4 GHz, 24 GB Ram | MacBook Pro 2.8GHz i7, 16GB Ram
10.8.4/10.10.4, UA Apollo Quad, PT 12.x

Tim D
Posts: 18
Joined: Sun Jan 30, 2005 12:48 am

Postby Tim D » Wed Nov 14, 2012 5:54 pm

Bump :) Any luck, guys?

Drew_BFDTeam
Posts: 3883
Joined: Fri Jul 21, 2006 5:32 pm
Location: London, UK

Postby Drew_BFDTeam » Mon Nov 19, 2012 3:57 pm

Heya; sorry for the delay!! (no pun intended!)

The fix for this is now up in the BFD2 downloads area; under the 'audio fixes' section. Please read the instructions at the start of the installer - don't just keep clicking next!

User avatar
AshleySmith08
Posts: 2206
Joined: Thu Dec 23, 2004 12:03 pm
Location: www.seattleunderground.co.uk
Contact:

Postby AshleySmith08 » Mon Nov 19, 2012 5:08 pm

Cheers Drew!! :D
Engineer/Producer/Musician/Media Content Creator
Website: http://www.seattleunderground.co.uk
CV: https://app.box.com/s/oiulec8q1eyqn2r0s46k
MacPro 12 Core 2x2.4 GHz, 24 GB Ram | MacBook Pro 2.8GHz i7, 16GB Ram
10.8.4/10.10.4, UA Apollo Quad, PT 12.x


Return to “BFD2”

Who is online

Users browsing this forum: No registered users and 16 guests