BFD2 simply don`t work -


FXpansion Forum

BFD2 simply don`t work

General FX news, discussion, and a place to speak your mind

Moderators: Drew_fx, john emrich, Mully_FX, mayur_FX, Angus_FX, Andreas_FX, Rory_FX, Rhi_FX, Paul_fx, clare_fx, SKoT_FX, Steve_FX, Moderators

Posts: 2
Joined: Tue Oct 05, 2004 5:19 pm

BFD2 simply don`t work

Postby EastM » Thu Mar 31, 2011 4:07 pm

Hello to all.
This is my first post on this forum and I write this to let go of quite a lot of frustration of the BFD2. Years ago I used BFD 1. up to 1.5 and it was great. I bought xpansion packs and looked greatly forward to the release of BFD2. BFD2 came, was installed with the data files on special defragmented disk. Upon launching in Cubase BFD2 show pictures of the drum sets, but refuse to load them, saying they`re either not there or that I`m not licenced to use them. Well, I bought them, which should include a licence to use them, and I know where I installed them, so they are there. And why should BFD2 show me drumsets I`m not able to use? Giving up BFD 1.5 and BFD2, I became a fortunate owner of XLN Audio`s Addictive Drums which is excelllent.
Here the other day I reinstalled both BFD 1.5 and BFD2 because I needed them for some old projects. The same saga again, useless software at a cost.
I guess BFD, whatever, is not for me. I need something that loads and plays so I can concentrate on music. Too bad with the money spent though........

Thanks for reading.

Posts: 3830
Joined: Fri Jul 21, 2006 5:32 pm
Location: London, UK

Postby Drew_fx » Thu Mar 31, 2011 4:20 pm

If you go into the BFD2 preferences, and check the DATA page - there is an entry for data-paths. Make sure your BFD2 data path is listed here, and click the button "trash and rescan databases" ... if that doesn't work, then a lot more information is needed. Such as where your BFD2 data is installed, and whether you've installed your expansion packs into the same directory or not.

This guide may help also:

Posts: 2
Joined: Tue Oct 05, 2004 5:19 pm

Postby EastM » Thu Mar 31, 2011 10:05 pm

Thanks a lot Drew_fx. I clicked the button "trash and rescan databases" and voila the authorization program started running and I had to fill some serials and then ....... it worked ! :D !

Actually I posted because I had given up the whole thing - but now it works.

So thanks again - I got a new software today!

Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 13 guests