Page 8 of 13

Re: macOS 10.15 Catalina compatibility

Posted: Mon Jan 27, 2020 5:01 am
by pippoxpansion
damn, this blows, I am personally done with this company.. won't buy a thing from FXpansion or ROLI anymore. As I understand you can't keep updating stuff perpetually.. as a customer it blows to see hundreds of dollars in investment vanish.. seriously
I would happily pay money to keep my plugins working with updates, and I would understand why they drop the old effects like MAUL, BLOOM etc.. but SYNTH SQUAD?? This seriously blows..

Re: macOS 10.15 Catalina compatibility

Posted: Mon Jan 27, 2020 12:57 pm
by Lawrence_fx
pippoxpansion wrote:sooo. this may sound like. stupid question, but I undesrstand GEIST 2, STROBE 2, CYPHER 2 got some work done and are OK with Catalina now.. but is there a plan to get also working BLOOM, ETCH, MAUL, TREMOR and DCAM SYNTH SQUAD?


We're looking into the feasibility of updating some of the legacy installers to allow these products to be installed on macOS Catalina - we'll let you know of any progress made.

Re: macOS 10.15 Catalina compatibility

Posted: Mon Jan 27, 2020 4:04 pm
by Norbert Mueller
Dave Magoo wrote:The following FXpansion instruments are now considered legacy products and as such will receive no further updates or support to ensure continued compatibility with modern operating systems and DAW hosts:
Bloom
DCAM Dynamics
DCAM SynthSquad
SynthSquad Packs
DR008
Etch
Guru
Geist
BFD Eco
BFD1
BFD2
Maul
Tremor
VST AU Adapter
VST RTAS Adapter

:cry:



This so bad. RME supports all old products, even from 2001! ROLI/FXpansion turned into a scam. :-(
STILL NO BFD3 DRIVER FOR CATALINA. It's just inexcusable.

Re: macOS 10.15 Catalina compatibility

Posted: Mon Jan 27, 2020 5:38 pm
by onlyleura
Lawrence_fx wrote:Hey Kit, there aren't any known issues with Strobe2 or Cypher2 and Catalina at this stage, so please feel free to install/update if this is the only FXpansion software you're running. Please do let us know if you encounter any issues, though.


You can rest assured, knowing that you'll definitely hear from me if I update to Catalina in-situ, and Strobe2 starts retching.

-Kit

Re: macOS 10.15 Catalina compatibility

Posted: Wed Jan 29, 2020 6:01 pm
by Lawrence_fx
Hi all,

We're pleased to say we've been able to repackage the following legacy products, to allow them to install and run on macOS Catalina - these can now be downloaded from your FXpansion account:

- DCAM Synth Squad
- Tremor
- Bloom
- Etch
- Maul

Work is continuing on updates to BFD3 and BFD Expansions, and we hope to bring you news very soon of when these updates will be available.

Re: macOS 10.15 Catalina compatibility

Posted: Fri Jan 31, 2020 7:19 am
by Jan.Schoene
Hi,

can't remember if it was mentioned - what about third party installers? Like eSoundz or Drumdrops. Will they have to upgrade their installers on their own? Can't see that with eSoundz to be honest - great stuff but they seem a little behind technically. Or are you building an installer that can somehow "read" and install old packs? That would be great anyway - one installer to install them all, just point to a folder where the packs are saved and hit "go" :D
For now I'm just copying all the stuff when i move to a new computer. But if the drive fails I only have the original installers on an external drive.

Cheers
Jan

Re: macOS 10.15 Catalina compatibility

Posted: Mon Feb 03, 2020 10:16 am
by Divarre
Lawrence_fx wrote:Hi all,

We're pleased to say we've been able to repackage the following legacy products, to allow them to install and run on macOS Catalina - these can now be downloaded from your FXpansion account:

- DCAM Synth Squad
- Tremor
- Bloom
- Etch
- Maul

Work is continuing on updates to BFD3 and BFD Expansions, and we hope to bring you news very soon of when these updates will be available.


Just installed DCAM Synth Squad on macOS 10.15.3 and they're working like a charm. Thanks FXpansion!

Re: macOS 10.15 Catalina compatibility

Posted: Thu Feb 06, 2020 3:24 pm
by plectrumboy
Divarre wrote:
Lawrence_fx wrote:Hi all,

We're pleased to say we've been able to repackage the following legacy products, to allow them to install and run on macOS Catalina - these can now be downloaded from your FXpansion account:

- DCAM Synth Squad
- Tremor
- Bloom
- Etch
- Maul

Work is continuing on updates to BFD3 and BFD Expansions, and we hope to bring you news very soon of when these updates will be available.


Just installed DCAM Synth Squad on macOS 10.15.3 and they're working like a charm. Thanks FXpansion!

Well, if Fxpansion can address Catalina issues with software they had previously classified as 'legacy', I hope I'll be able to say the same thing with BFD3 soon... :mrgreen:

Re: macOS 10.15 Catalina compatibility

Posted: Thu Feb 06, 2020 4:03 pm
by Lawrence_fx
plectrumboy wrote:
Divarre wrote:
Lawrence_fx wrote:Hi all,

We're pleased to say we've been able to repackage the following legacy products, to allow them to install and run on macOS Catalina - these can now be downloaded from your FXpansion account:

- DCAM Synth Squad
- Tremor
- Bloom
- Etch
- Maul

Work is continuing on updates to BFD3 and BFD Expansions, and we hope to bring you news very soon of when these updates will be available.


Just installed DCAM Synth Squad on macOS 10.15.3 and they're working like a charm. Thanks FXpansion!

Well, if Fxpansion can address Catalina issues with software they had previously classified as 'legacy', I hope I'll be able to say the same thing with BFD3 soon... :mrgreen:


We're getting ever closer each day. Thanks for hanging in there

Re: macOS 10.15 Catalina compatibility

Posted: Fri Feb 07, 2020 1:01 pm
by fabsqueak
BFD 3 is my go to, but still no update for Catalina. I'am really sad.
Do you have an alternative to offer ?

Re: macOS 10.15 Catalina compatibility

Posted: Fri Feb 07, 2020 9:20 pm
by i2mls@me.com
Time to move on... Just upgraded to Toontrack Superior Drummer3. I waited 2-months for BFD, but sadly we all can't simply stop making music!!! Fxpansion must be in trouble, as this is just not acceptable behavior.

X Customer
Michael Shannon

Re: macOS 10.15 Catalina compatibility

Posted: Sat Feb 08, 2020 12:56 am
by mvcl
In light of all of the inconvenience we've suffered from waiting so long (and still ongoing) and PAIN from having to revert our machines via fresh installs of Mojave after Catalina, with all of the tedious reinstallation of the software packages, apps, helpers, fonts, utilities, etc. and system configurations which are entailed in that, I have a suggestion. It would be a welcome gesture if FXPansion were to gift to us the full run of BFD3 expansion packs to explore and enjoy. I've always been curious, and I've always been a loyal customer (I've bought all of FXPansion's products). Whatever the cost to the company, this would be a very-much appreciated gesture to us for sticking around so patiently. We could have an understanding too that we would pay for any of the packs we use in commerce, otherwise the packs to us would be NFR (not for resale) non-transferable, and for review only.
Why not?
[Addition on 13-Feb-2020: I'm serious in making this request. Please email me the details!]

Re: macOS 10.15 Catalina compatibility

Posted: Sat Feb 08, 2020 2:24 am
by LesSand
Agreed.

I would even go as far as arguing that the loss in revenue stands to be minimal to non-existent.

Given the damage in reputation that this delay has caused, I don't think many of users and fans - especially the ones who have been following this thread -- are inclined to sink any more money on BFD expansions and other FXpansion products.

A material gesture of appreciation would win back the trust of some of us with virtually zero cost and only a potential deferral/forfeiture of future income -- income that is far from certain at this point.

Self-interest notwithstanding, not only I'd appreciate such a token, I would also consider it sound business reasoning.

-Les

Re: macOS 10.15 Catalina compatibility

Posted: Sat Feb 08, 2020 2:44 am
by Nelifedo
New user chiming in here...
Embarrassing.

Went back to addictive drums. Fckng waste of money here

Re: macOS 10.15 Catalina compatibility

Posted: Sat Feb 08, 2020 10:30 am
by fenderman
Hi

Is this issue with Catalina ever going to be resolved ? there has been ample time now, or are you no longer going to support BFD, but not told customers yet ?
Please advise so that other alternatives can be considered if you are not going to support customers.

Thanks

Tim