macOS 10.15 Catalina compatibility - Page 3 - Fxpansion.com

Forum

FXpansion Forum

macOS 10.15 Catalina compatibility

General FX news, discussion, and a place to speak your mind

Moderators: Drew_fx, clare_fx, SKoT_FX, Steve_FX, john emrich, Mully_FX, mayur_FX, Angus_FX, Andreas_FX, Rory_FX, Rhi_FX, Paul_fx, Moderators

williambogard
Posts: 4
Joined: Wed Nov 27, 2019 4:40 pm

Re: macOS 10.15 Catalina compatibility

Postby williambogard » Wed Nov 27, 2019 4:48 pm

I would like to take advantage of black friday discounts for BFD3, but I am on catalina which is not currently supported for installation. should I purchase now, wait, or what?

Lawrence_fx
Posts: 542
Joined: Thu Mar 10, 2016 8:19 pm

Re: macOS 10.15 Catalina compatibility

Postby Lawrence_fx » Wed Nov 27, 2019 6:05 pm

williambogard wrote:I would like to take advantage of black friday discounts for BFD3, but I am on catalina which is not currently supported for installation. should I purchase now, wait, or what?


We're aiming to complete these updates as soon as possible, but we recommend reaching out to the support team regarding any purchases you're looking to make: https://support.roli.com/request

williambogard
Posts: 4
Joined: Wed Nov 27, 2019 4:40 pm

Re: macOS 10.15 Catalina compatibility

Postby williambogard » Thu Nov 28, 2019 5:07 pm

roli support said I would have to purchase BFD3 now to get the black friday discount, then wait for an updated installer to work w/ catalina. which I did. hope the update will come soon and that it will work.

Stromkraft
Posts: 10
Joined: Mon Dec 30, 2013 7:05 am

Re: macOS 10.15 Catalina compatibility

Postby Stromkraft » Wed Dec 04, 2019 9:07 am

What about older software like Tremor? I'd be happy if it just worked as is and got those notarized things in place for when Apple puts the clamp down on installers without it. I mean it's a great 64bit app and should work in macOS 10.15 Catalina even without a few bug fixes. I can't even remember what those bugs are anyway.

Tremor is unique, great and wonderful. Please, please, do not abandon it.

Lawrence_fx
Posts: 542
Joined: Thu Mar 10, 2016 8:19 pm

Re: macOS 10.15 Catalina compatibility

Postby Lawrence_fx » Wed Dec 04, 2019 9:51 am

Stromkraft wrote:What about older software like Tremor? I'd be happy if it just worked as is and got those notarized things in place for when Apple puts the clamp down on installers without it. I mean it's a great 64bit app and should work in macOS 10.15 Catalina even without a few bug fixes. I can't even remember what those bugs are anyway.

Tremor is unique, great and wonderful. Please, please, do not abandon it.


Thanks for the feedback - given that Tremor is no longer supported, there are no current plans to provide an update for 10.15. However, we'll look into the feasibility of this.

wolvesplaymusic
Posts: 1
Joined: Thu Aug 17, 2017 3:43 am

Re: macOS 10.15 Catalina compatibility

Postby wolvesplaymusic » Thu Dec 05, 2019 8:37 pm

Lawrence_fx wrote:
Stromkraft wrote:What about older software like Tremor? I'd be happy if it just worked as is and got those notarized things in place for when Apple puts the clamp down on installers without it. I mean it's a great 64bit app and should work in macOS 10.15 Catalina even without a few bug fixes. I can't even remember what those bugs are anyway.

Tremor is unique, great and wonderful. Please, please, do not abandon it.


Thanks for the feedback - given that Tremor is no longer supported, there are no current plans to provide an update for 10.15. However, we'll look into the feasibility of this.


Please do!
Tremor, Bloom, Etch, and Maul were all very much heavily used by me (especially Tremor) and purchased within the last two years.
Sad to see an abrupt end of life :(

tappazee
Posts: 19
Joined: Thu Jul 09, 2015 5:20 pm

Re: macOS 10.15 Catalina compatibility

Postby tappazee » Sat Dec 07, 2019 10:42 am

marcbus27@comcast.net wrote:I can’t get the export function to work since upgrading. The status goes from armed to “starting” ( instead of “recording”j during export and the files produced are empty (44mb). It was working before Catalina. So far everything else works.


Is this in regard to Geist2? If not, does anyone have experience running Geist2 on Catalina yet? It's already installed so the non-functional installers not a problem for me.

amasters46250
Posts: 1
Joined: Sat Dec 07, 2019 5:14 pm

Re: macOS 10.15 Catalina compatibility

Postby amasters46250 » Sat Dec 07, 2019 9:14 pm

When will this be compatible with Catalina? I purchased this software earlier today, but the installer script wouldn't work. Please advise.

Lawrence_fx
Posts: 542
Joined: Thu Mar 10, 2016 8:19 pm

Re: macOS 10.15 Catalina compatibility

Postby Lawrence_fx » Mon Dec 09, 2019 9:29 am

amasters46250 wrote:When will this be compatible with Catalina? I purchased this software earlier today, but the installer script wouldn't work. Please advise.


Hi, which product specifically are you experiencing issues with? Please reach out to our support team who will be able to advise: https://support.roli.com/request

edxter
Posts: 11
Joined: Mon May 17, 2010 7:48 am

Re: macOS 10.15 Catalina compatibility

Postby edxter » Mon Dec 09, 2019 9:46 am

I had to do a clean reinstall of Catalina and now I can't install BFD3 from scratch, I miss those wooden snares and the jazz noir :cry:

keagannelson13
Posts: 1
Joined: Fri Mar 27, 2015 1:18 am

Re: macOS 10.15 Catalina compatibility

Postby keagannelson13 » Fri Dec 13, 2019 2:07 am

any updates on when the installer might be ready?
ive had a few projects on hold waiting.

Lawrence_fx
Posts: 542
Joined: Thu Mar 10, 2016 8:19 pm

Re: macOS 10.15 Catalina compatibility

Postby Lawrence_fx » Fri Dec 13, 2019 10:03 am

keagannelson13 wrote:any updates on when the installer might be ready?
ive had a few projects on hold waiting.


We've made some good progress, no clear date yet but we're closer. We'll let you know once the updates are available, thanks for your patience.

marcbus27@comcast.net
Posts: 5
Joined: Mon Apr 30, 2007 4:43 pm

Re: macOS 10.15 Catalina compatibility

Postby marcbus27@comcast.net » Sat Dec 14, 2019 6:03 pm

When the Catalina update comes, will it resolve the issue with host sync export?

iliealing
Posts: 10
Joined: Tue Jul 22, 2008 10:33 pm

Re: macOS 10.15 Catalina compatibility

Postby iliealing » Sat Dec 21, 2019 10:54 am

I hope the update arrives before the release of OSX 10.16. Seeing how fxexpansion has handled this recent update I do not have to much expectations anymore. Maybe start looking for an alternative sampler. :oops:

Damagical
Posts: 19
Joined: Wed Mar 30, 2011 10:03 pm

Re: macOS 10.15 Catalina compatibility

Postby Damagical » Sun Dec 22, 2019 3:42 am

Iliealing, you have to give these things time. New macs are selling now with Catalina and Fxpansion wants to be able to keep selling their products. Apple made some big changes with Catalina that are causing a lot of developers a lot of difficulty, and though I do not know if this is the case for Fxpansion, developers have to apply to Apple for exemptions in some cases for the software to run properly, and that happens when Apple gets around to it. If you want a clear idea of how many problems this is causing for pro audio developers.. try looking at this list:

https://www.pro-tools-expert.com/produc ... s-1015-yet

..Look at how many pro audio applications have essentially been broken by Catalina.. ..this takes time. All those developers want to get their products fully compatible (and marketable, they're all losing money if they can't sell them) but there are processes and consultations with Apple etc. that take time. Some of these problems are likely bugs Apple introduced with Catalina that Apple themselves have to correct in later updates, and Apple has their own schedules and priorities for such things.

Adapting a newly released major update is always risky and if you look at that list I linked.. it is followed by developer after developer advising against upgrading to Catalina at this time. If you decided to upgrade and didn't research the developers of your software for upgrade advice- that's your own naivety and this is going to be a learning process for you. If you are waiting to upgrade- be patient- most major upgrades have a period of about 12 months for these things to be nailed out.

Apple has done a major overhaul, for the sake of security, of what disk resources developers have access to- and if developers need to be able to access sample libraries etc, then I imagine they have to wait for apple to decide how Apple wants to proceed with exemptions, patches, etc. so the developers can move forward.

Patience.


Return to “General Discussion”

Who is online

Users browsing this forum: Majestic-12 [Bot] and 8 guests