Page 1 of 1

Geist Download Link Problem

Posted: Wed Nov 17, 2010 7:08 pm
by malc-88
Hi Everyone,

I've just purchased Geist but I'm having a little problem with the Geist download link(s) in my account and wanted to know if anyone else has experienced the same issue. It seems that the first link is classified as an unknown file type which results in me being unable to open the file once it's downloaded. The other two links are classified as .zip files so I'll have no problem opening them in Winzip but I can't install the software unless I am able to open the first file. Has anyone else encountered a similar problem? Thank you for your replies and have a great day!

Posted: Wed Nov 17, 2010 7:13 pm
by Airyck
Just try renaming the unknown file so that it has the extention .zip, then try opening it. You can always change it back to it's current extention if it doesn't work.

What is the current extention BTW?

Posted: Wed Nov 17, 2010 7:29 pm
by malc-88

Thanks for your reply. The file type in explorer is PART1(1) File. I believe this is the same description given for the link in my account also. I took your advice and converted the file type over to .zip and it appears to be extracting properly now. If I have any further problems with this I'll post back. If not, thank you once again for your help and have a great day!

Posted: Wed Nov 17, 2010 7:34 pm
by Airyck
I'm glad it's working so far.

The Part1 file usually means the the file is a partial download, it's possible that the file didn't finish downloading all the way. It's also possible that it just stopped at the very end and didn't convert to a .zip. I've had it happen before and just converting the file worked.

Make sure the file seems a reasonably large size, if any samples or anything are missing afterwards it's a good chance it wasn't a completed download.

Good luck and have fun, can't wait to get home and try the demo!

Posted: Wed Nov 17, 2010 7:50 pm
by malc-88
I'm back again. Looks like Winzip can't open the file because it is an invalid archive. I check the link again. I'll see if I can get some help from support also. Thanks and have a great day!

Posted: Wed Nov 17, 2010 7:51 pm
by Drew_fx
Part 1 of the download is a self extracting EXE.

Part 2 and 3 are RAR files. You need all three files, completely downloaded, in the same directory. Once you've got that - run the EXE.

It sounds as if the download timed out to me. Please refresh your Geist product downloads page, and try downloading again.

Posted: Wed Nov 17, 2010 8:22 pm
by malc-88

I tried downloading again but I still have the same problem. Windows does not recognize the file extension and can't open it. Is there any way you could send me a direct link? Thank you and have a great day!

Posted: Wed Nov 17, 2010 8:24 pm
by Drew_fx
Are you using some kind of download manager? Which browser are you using?

Posted: Wed Nov 17, 2010 8:28 pm
by malc-88
I'm using Internet Explorer (latest version). I don't have any unusual tweaks on my computer. I've never had any problems downloading from this website before.

Posted: Wed Nov 17, 2010 9:38 pm
by malc-88
When I click on the link in my account to download the file, the dialog box states that the file type is unknown. I hope this helps towards finding a solution. Once again this is on an ordinary machine using Internet Explorer.

Posted: Thu Nov 18, 2010 3:49 am
by dcspears
also having trouble downloading Geist. Downloads are timing out, haven't been able to download any of the three parts succesfully. I imagine there's heavy activity with the launch. I'll try a little later.

Posted: Thu Nov 18, 2010 4:27 am
by malc-88
I was finally able to successfully install and activate Geist. It turned out that the .exe is missing (at least for me) from the filename of the first download. Once I manually added the file extension, everything worked out OK.

Posted: Thu Nov 18, 2010 6:46 am
by dcspears
still unable to succesfully download any of the parts. download will slow to crawl and then stop. have yet to reach even 30% on any part. hmm?

Posted: Thu Nov 18, 2010 6:48 am
by SKoT_FX
What web browser are you using, and what version? Do you have any download-manager plugins?

Posted: Thu Nov 18, 2010 7:13 am
by dcspears
I've tried on three different browsers (firefox, chrome, and ie). All up to date and no download managers. I'll try again.