Problem running some Fxpansion installers on OSX Yosemite -


FXpansion Forum

Problem running some Fxpansion installers on OSX Yosemite

Product Support for BFD3

Moderator: Moderators

Posts: 3
Joined: Fri Feb 08, 2013 1:41 am

Problem running some Fxpansion installers on OSX Yosemite

Postby safer » Mon Mar 30, 2015 1:26 pm

This is really strange and I'm hoping someone out there may be able to help.

I recently purchased the Sonic Reality Nick Mason BFD expansion, downloaded and extracted the files just fine, but when I tried to run the installer I just got the error message "The application can't be opened". BTW, this exact same thing happens when I try to run the installer for the latest DCAM Synth Squad beta. This message is not due to the Gatekeeper settings on my Mac, as I've already got them set to allow applications downloaded from anywhere to execute, and I have not had any problem with other installers that I've downloaded. I've also tried the "repair permissions on the files" route, but have had no luck there either.

After searching in vane for a solution, or even for someone else having the same problem, I tried burning the extracted installation files to a DVD and guess what? I found that both the Nick Mason kit installer and DCAM Synth Squad installers will run just fine from a DVD. However, after the Nick Mason kit installer reported that it completed successfully, I launched FX License Manager to authorize the kit but it shows the Nick Mason kit with an "X" next to it and a status of "software is not installed properly, please reinstall" (which I've done twice but got the same results each time). The Nick Mason kit is in its own folder on an external hard drive attached to the Mac, just like all of the other expansions I have purchased.

So first, does anybody have any idea why these installers will not run when I try and run them from the local hard drive on my Mac, but will run from a DVD?

And second, why does the FX License Manager report the Nick Mason kit as not being installed properly when the installer reports a successful installation? And what do I do to fix this?

Thanks in advance for any help or advice. If I've left out any details please let me know.

Kind Regards,
Steve Ferraro

Posts: 1
Joined: Sun Nov 18, 2007 12:27 am

Postby sonic643 » Sun Aug 23, 2015 10:44 pm

same problem here...

Posts: 104
Joined: Fri Dec 23, 2005 2:07 pm
Location: Dortmund, Germany

Postby Jan.Schoene » Mon Aug 24, 2015 6:09 am

As for the message try right-clicking the installer and choose "open". In the next window choose "open" again and it will work fine.
Maybe the problem with the License-Manager disappears.
However I had this problem once with an expansion from esoundz, too. Do you have the latest version of the License Manager and BFD installed?
Did you try installing it for BFD2 (and 3) or only for BFD3? Anyway try it the other way round and give it a go.
To avoid questions:
MacBook Pro Retina, Core i7 2,6GHz, 16GB RAM, OS X 10.14.6, Logic Pro X, Cubase Pro 10, BFD3 (always latest stable), BFD Eco, BFD Eco DV

User avatar
Promulgator of Beats
Posts: 2375
Joined: Tue Sep 21, 2004 9:51 am
Location: FX Australia, Perth

Postby SKoT_FX » Thu Aug 27, 2015 5:43 am

Hi Steve, are you just using the vanilla dearchiver (if dmg or ip, then OSX itself)

Sounds like it might be a permissions issue we/DrumDrops may need to sort out. Burning to DVD is probably bypassing any new special file permission settings recently introduced. Can I get your exact version of OSX?

If you are au fait with Terminal, you can blast thru any recalcitrant permissions with these commands. Replace the stuff in the angle brackets:

cd <enter the root folder of the installer, or drag and drop the folder icon - easier!>
chmod -R a+wrx *

What those commands do:
ch "change directory"
chmod "Change file permissions mode" -R "Recursive (ie, subfolders roo)" a+wrx "All Users, read, write and execute" * "star to match all files"
SKoT McDonald
CTO FXpansion]

Posts: 3
Joined: Fri Feb 08, 2013 1:41 am

Problem solved!

Postby safer » Wed Sep 16, 2015 1:01 pm


I am running OSX Yosemite 10.10.5.

To answer your question about the dearchiver, I was using the free Keka utility and this was set as the default program for opening archives. After reading your question, I tried right-clicking on the package, then selecting "Open With" and then "Archive Utility", and now the unarchived installer runs just fine.

Don't know why I didn't think to try that, but it worked!

Thanks for your assistance.


Return to “BFD3”

Who is online

Users browsing this forum: No registered users and 3 guests